_content/doc: document 'go get' requiring version for @patch

For golang/go#37438

Change-Id: I077f364a4c484de4b5f1554207bfd250947198e6
Reviewed-on: https://go-review.googlesource.com/c/website/+/287415
Trust: Jay Conrod <jayconrod@google.com>
Reviewed-by: Bryan C. Mills <bcmills@google.com>
diff --git a/_content/doc/mod.md b/_content/doc/mod.md
index b115544..61aa0cf 100644
--- a/_content/doc/mod.md
+++ b/_content/doc/mod.md
@@ -2016,7 +2016,9 @@
   (for example, a pre-release), `upgrade` will select the current version.
 * The string `patch`, which selects the latest available version with the same
   major and minor version numbers as the currently required version. If no
-  version is currently required, `patch` is equivalent to `latest`.
+  version is currently required, `patch` is equivalent to `latest`. Since
+  Go 1.16, [`go get`](#go-get) requires a current version when using `patch`
+  (but the `-u=patch` flag does not have this requirement).
 
 Except for queries for specific named versions or revisions, all queries
 consider available versions reported by `go list -m -versions` (see [`go list