all: remove build restrictions requiring go1.18

govulncheck's go.mod file explicitly requires go1.21 and it can analyze
binaries built before go1.18. There is no need to have these build

Change-Id: I50a80da2490fd4bd8fb3d5b7a68f8796ff3ffe18
LUCI-TryBot-Result: Go LUCI <>
Reviewed-by: Maceo Thompson <>
6 files changed
tree: 61c88cd04411b98eb6b2776d35e648351f6726e3
  1. cmd/
  2. doc/
  3. internal/
  4. scan/
  5. .gitignore
  6. all_test.go
  8. go.mod
  9. go.sum

Go Vulnerability Management

Go Reference

Go's support for vulnerability management includes tooling for analyzing your codebase and binaries to surface known vulnerabilities in your dependencies. This tooling is backed by the Go vulnerability database, which is curated by the Go security team. Go’s tooling reduces noise in your results by only surfacing vulnerabilities in functions that your code is actually calling.

You can install the latest version of govulncheck using go install

go install

Then, run govulncheck inside your module:

govulncheck ./...

See the govulncheck tutorial to get started, and for more information about Go's support for vulnerability management. The API documentation can be found at

Privacy Policy

The privacy policy for govulncheck can be found at


Unless otherwise noted, the Go source files are distributed under the BSD-style license found in the LICENSE file.

Database entries available at are distributed under the terms of the CC-BY 4.0 license.